Request for 3.2.2 Prime.ipa
on Sunday, March 11, 2018 - 1:42am
Sunday, March 11, 2018 - 1:42am

Hello anyone, does anyone have the 3.2.2 Prime.ipa file they could email me? I am having a lot of problems with Prime 4.0. I didn't backup my Prime 3.2.2 .ipa file like I should have in case I needed to downgrade and now I'm stuck on 4.0.

The audio cracks and pops in my sound system if I am clicking on the settings icon while music is playing or if I am adjusting one of my iOS VST instruments via AUM.

Also, my Click and Cue track is out of sync and the ability to replay a chorus and verse is currently not even working properly anymore because it will jump into the middle after the end of the section.

I have tried rebooting my iPad, uninstalling the songs OFF and back ON my iPad, uploading the tracks to the server again, removing all of the markers and redoing them again. Nothing has worked...

It's 1:00 in the morning where I am at and I have church in a few hours. I have no idea how I am getting through service tomorrow since my music isn't working correctly.

If anyone could please email me the previous version of the Prime app I would GREATLY appreciate it! 3.2.2 Prime.ipa

Thanks all,
I still love the Loop Community Prime App =) It's just too buggy for me to use currently lol. I'll take the old version until some more things are ironed out. Keep up the great work!

  • Staff
Wednesday, March 14, 2018 - 11:27am

Hey Derrick!

I am very sorry for the issues you are having with PRIME 4.0. None of this should be happening. Try logging out of PRIME and then force quitting the app by double tapping the home button on the iPad and then swiping the app away. If the problem is still there when you log back in, make sure you are removing the songs from the device by clicking "Add Song", then "Edit", then click the red button to delete and remove the song. Once it is removed, redownload it back to your device by clicking it in your track list. If these do not solve the issue:
1. Is this happening with all of your songs, or just one?
2. Are you connected to an interface when you hear the audio cracks and pops?

Hope this helps! We will help you get to the bottom of this. Thanks for being a part of the community!
-Derek, The LC Team

Wednesday, March 14, 2018 - 12:06pm

Hi Derek, I tried all of the above mentioned solutions right now, no luck...

1. This is what I noticed so far, for the songs that I uploaded before the 4.0 update, they seem to work fine. I have tried several of them and the click is perfectly lined up and the cues are working fine.
On the song I uploaded AFTER the 4.0 update, it doesn't work for me. The click starts out fine and by the first 20-30 seconds in the song, the click is way off track and so all of the cues are not synced up anymore. I have included a link to my dropbox that contains the stems from the song example I am using, if your development wants to try it out as well. It's about a 50mb in size. Also, I have the picture of my markers that I created on the song as well. I did reupload the track 2 times already just in case there was some sort of corruption on the upload process, but I still got the same results. Also I did a double check on my stems in Logic Pro X and I verified that the BPM was indeed set to 103 on the exporting of the stems. This was what I also input on the upload for the stems on the Prime Cloud upload website. I am out of ideas to try lol.

Song Demo:

2. As far as the popping, its anytime I really put my iPad Pro under stress while the music is playing, for example clicking the settings button a couple times while the song is being played or if I move over to AUM while the music is playing. I typically do this if my own VSTs on my iPad need to be adjusted volume wise or if I am switch instruments in the middle of a song. With 3.2.2, I never had any iPad sound popping issues like I am in 4.0.

Anyways, thats the basics of what I am working with=)
Thanks for getting back to me lol. I am hoping to have it ready by this next Sunday, it was pretty rough at our church last week lol=)